changeset 248:2dcbfb21d30b

fix the 3.0.0 ebuild
author Dirk Olmes <dirk@xanthippe.ping.de>
date Mon, 04 Oct 2010 19:46:49 +0200
parents ee84db816ec9
children eb2eb7604e50
files dev-java/maven-bin/maven-bin-3.0.0.ebuild
diffstat 1 files changed, 7 insertions(+), 1 deletions(-) [+]
line wrap: on
line diff
--- a/dev-java/maven-bin/maven-bin-3.0.0.ebuild	Mon Oct 04 19:45:38 2010 +0200
+++ b/dev-java/maven-bin/maven-bin-3.0.0.ebuild	Mon Oct 04 19:46:49 2010 +0200
@@ -30,15 +30,21 @@
 	rm -v "${S}"/bin/*.bat || die
 }
 
-# TODO we should use jars from packages, instead of what is bundled
 src_install() {
 	dodir "${MAVEN_SHARE}"
 	cp -Rp bin boot conf lib "${D}/${MAVEN_SHARE}" || die "failed to copy"
 
 	java-pkg_regjar "${D}/${MAVEN_SHARE}"/lib/*.jar
+	
+	# the Maven distro comes with really weird permissions in the tarball 
+	# which will cause the ebuild to preserve these weird permissions, leaving
+	# users with a broken maven installationy
+	chown root: "${D}/${MAVEN_SHARE}"/lib/*.jar "${D}/${MAVEN_SHARE}"/boot/*.jar
+	chmod 644  "${D}/${MAVEN_SHARE}"/lib/*.jar "${D}/${MAVEN_SHARE}"/boot/*.jar
 
 	dodoc NOTICE.txt README.txt || die
 
 	dodir /usr/bin
 	dosym "${MAVEN_SHARE}/bin/mvn" /usr/bin/mvn-${SLOT}
 }
+