changeset 207:351591dc4568

graphicsmagick is up to date in portage
author holger
date Thu, 11 Mar 2010 20:13:52 +0100
parents 3905a1b1ad46
children d601505de5aa
files media-gfx/graphicsmagick/Manifest media-gfx/graphicsmagick/files/graphicsmagick-1.3.7-debian-fixed.patch media-gfx/graphicsmagick/files/graphicsmagick-1.3.7-perl-ldflags.patch media-gfx/graphicsmagick/graphicsmagick-1.3.12.ebuild media-gfx/graphicsmagick/metadata.xml
diffstat 5 files changed, 0 insertions(+), 545 deletions(-) [+]
line wrap: on
line diff
--- a/media-gfx/graphicsmagick/Manifest	Wed Mar 10 16:04:21 2010 +0100
+++ /dev/null	Thu Jan 01 00:00:00 1970 +0000
@@ -1,5 +0,0 @@
-AUX graphicsmagick-1.3.7-debian-fixed.patch 14493 RMD160 cbeccbd775d60da7f2b498540fdef8b08189eeb6 SHA1 2da7acdf46401cbc294170919c592cb842ab2afa SHA256 da17fbb6e30ca42b2d07871cc730de8f5ad61df9387cf22948fe1dcb72263b8c
-AUX graphicsmagick-1.3.7-perl-ldflags.patch 991 RMD160 e234224a939892f04a82b83e48ef475318183b28 SHA1 5e5c89d808bd3040945c64a60e1f8df35c03053d SHA256 f1ff9bf3009b1e353089ed27067bee2895b4e7f0d9e15100abdebac20bef8644
-DIST GraphicsMagick-1.3.12.tar.bz2 6690493 RMD160 0a2749ee38a63c00c3ee6259ea7ea65c2bccc621 SHA1 6b8a414af162ad8679f2f04b10f128edc8ee3233 SHA256 4ceea8558c959fba847b2a4cd92232aac37f5f6a59dda234bc17ef83b90e57d7
-EBUILD graphicsmagick-1.3.12.ebuild 3409 RMD160 111f045306f990515046fbde00594e1a2d98e62f SHA1 86940fd5a809892ea553a480c0589289b5635021 SHA256 dd84b1554a23d6d04ae3dcb5a1d4465a77fbbf8dc23d246ddf49beb0a65d0bcc
-MISC metadata.xml 979 RMD160 0a2a8648f7f56281f4db1f845c37865b3cbb64df SHA1 5ddee256c96236652983e56ed0a991e09b9b6c7e SHA256 73b9a3ba1b91780cdfbe20744ad4101170ad271d6df529621406382f59cbf29f
--- a/media-gfx/graphicsmagick/files/graphicsmagick-1.3.7-debian-fixed.patch	Wed Mar 10 16:04:21 2010 +0100
+++ /dev/null	Thu Jan 01 00:00:00 1970 +0000
@@ -1,366 +0,0 @@
-Index: GraphicsMagick-1.3.7/magick/delegate.c
-===================================================================
---- GraphicsMagick-1.3.7.orig/magick/delegate.c
-+++ GraphicsMagick-1.3.7/magick/delegate.c
-@@ -454,7 +454,10 @@ MagickExport unsigned int InvokeDelegate
-   char
-     *command,
-     **commands,
--    filename[MaxTextExtent];
-+    linkedname[MaxTextExtent],
-+    linkedinfoname[MaxTextExtent],
-+    filename[MaxTextExtent],
-+    safechars[]="abcdefghijklmnopqrstuvwxyzABCDEFGHIJKLMNOPQRSTUVWXYZ0123456789.,-_+ /";
- 
-   const DelegateInfo
-     *delegate_info;
-@@ -474,6 +477,10 @@ MagickExport unsigned int InvokeDelegate
-   assert(image != (Image *) NULL);
-   assert(image->signature == MagickSignature);
-   temporary_image_filename=(*image->filename == '\0');
-+  linkedname[0]='\0';
-+  linkedname[MaxTextExtent-1]='\0';
-+  linkedinfoname[0]='\0';
-+  linkedinfoname[MaxTextExtent-1]='\0';
-   if (temporary_image_filename)
-     {
-       /* Allocate a temporary filename if image is unnamed.  */
-@@ -483,12 +490,24 @@ MagickExport unsigned int InvokeDelegate
-           return(False);
-         }
-     }
-+  else if (strspn(image->filename, safechars) != strlen(image->filename))
-+    {
-+      strncpy(linkedname,image->filename,MaxTextExtent-1);
-+      if (!AcquireTemporarySymlink(image->filename,linkedname))
-+	{
-+          (void) ThrowException(exception,FileOpenError,UnableToCreateTemporaryFile,image->filename);
-+	  return (False);
-+	}
-+    }
-+
-   (void) strlcpy(filename,image->filename,MaxTextExtent);
-   delegate_info=GetDelegateInfo(decode,encode,exception);
-   if (delegate_info == (DelegateInfo *) NULL)
-     {
-       if (temporary_image_filename)
-         (void) LiberateTemporaryFile(image->filename);
-+      if (*linkedname)
-+	strncpy(image->filename,linkedname,MaxTextExtent-1);
-       (void) ThrowException(exception,DelegateError,NoTagFound,
-         decode ? decode : encode);
-       return(False);
-@@ -509,6 +528,18 @@ MagickExport unsigned int InvokeDelegate
-         }
-       image_info->temporary=True;
-     }
-+  else if (strspn(image_info->filename, safechars) != strlen(image_info->filename))
-+    {
-+      strncpy(linkedinfoname,image_info->filename,MaxTextExtent-1);
-+      if (!AcquireTemporarySymlink(image_info->filename,linkedinfoname))
-+	{
-+          if (temporary_image_filename)
-+            LiberateTemporaryFile(image->filename);
-+          (void) ThrowException(exception,FileOpenError,UnableToCreateTemporaryFile,image_info->filename);
-+          return(False);
-+        }
-+      temporary_image_filename=True;
-+    }
- 
-   if (delegate_info->mode != 0)
-     if ((decode && (delegate_info->encode != (char *) NULL)) ||
-@@ -532,6 +563,13 @@ MagickExport unsigned int InvokeDelegate
-         {
-           if (temporary_image_filename)
-             (void) LiberateTemporaryFile(image->filename);
-+	  if (*linkedname)
-+            strncpy(image->filename,linkedname,MaxTextExtent-1);
-+	  if (*linkedinfoname)
-+            {
-+              LiberateTemporaryFile(linkedinfoname);
-+              strncpy(image_info->filename,linkedinfoname,MaxTextExtent-1);
-+	    }
-           (void) ThrowException(exception,FileOpenError,UnableToCreateTemporaryFile,image_info->unique);
-           return(False);
-         }
-@@ -540,6 +578,13 @@ MagickExport unsigned int InvokeDelegate
-         {
-           if (temporary_image_filename)
-             (void) LiberateTemporaryFile(image->filename);
-+	  if (*linkedname)
-+            strncpy(image->filename,linkedname,MaxTextExtent-1);
-+	  if (*linkedinfoname)
-+            {
-+              LiberateTemporaryFile(linkedinfoname);
-+              strncpy(image_info->filename,linkedinfoname,MaxTextExtent-1);
-+	    }
-           (void) LiberateTemporaryFile(image_info->unique);
-           (void) ThrowException(exception,FileOpenError,UnableToCreateTemporaryFile,image_info->zero);
-           return(False);
-@@ -553,6 +598,13 @@ MagickExport unsigned int InvokeDelegate
-             (void) LiberateTemporaryFile(image_info->zero);
-             if (temporary_image_filename)
-               (void) LiberateTemporaryFile(image->filename);
-+	    if (*linkedname)
-+              strncpy(image->filename,linkedname,MaxTextExtent-1);
-+	    if (*linkedinfoname)
-+              {
-+                LiberateTemporaryFile(linkedinfoname);
-+                strncpy(image_info->filename,linkedinfoname,MaxTextExtent-1);
-+	      }
-             (void) ThrowException(exception,DelegateError,DelegateFailed,
-               decode ? decode : encode);
-             return(False);
-@@ -578,6 +630,13 @@ MagickExport unsigned int InvokeDelegate
-               (void) LiberateTemporaryFile(image_info->zero);
-               if (temporary_image_filename)
-                 (void) LiberateTemporaryFile(image->filename);
-+	      if (*linkedname)
-+                strncpy(image->filename,linkedname,MaxTextExtent-1);
-+	      if (*linkedinfoname)
-+                {
-+                  LiberateTemporaryFile(linkedinfoname);
-+                  strncpy(image_info->filename,linkedinfoname,MaxTextExtent-1);
-+	        }
-               DestroyImageInfo(clone_info);
-               (void) ThrowException(exception,DelegateError,DelegateFailed,
-                 decode ? decode : encode);
-@@ -599,6 +658,13 @@ MagickExport unsigned int InvokeDelegate
-     {
-       if (temporary_image_filename)
-         (void) LiberateTemporaryFile(image->filename);
-+      if (*linkedname)
-+        strncpy(image->filename,linkedname,MaxTextExtent-1);
-+      if (*linkedinfoname)
-+        {
-+          LiberateTemporaryFile(linkedinfoname);
-+          strncpy(image_info->filename,linkedinfoname,MaxTextExtent-1);
-+        }
-       (void) ThrowException(exception,ResourceLimitError,MemoryAllocationFailed,decode ? decode : encode);
-       return(False);
-     }
-@@ -733,6 +799,13 @@ MagickExport unsigned int InvokeDelegate
-  error_exit:
-   if (temporary_image_filename)
-     (void) LiberateTemporaryFile(image->filename);
-+  if (*linkedname)
-+    strncpy(image->filename,linkedname,MaxTextExtent-1);
-+  if (*linkedinfoname)
-+    {
-+      LiberateTemporaryFile(linkedinfoname);
-+      strncpy(image_info->filename,linkedinfoname,MaxTextExtent-1);
-+    }
-   for ( ; commands[i] != (char *) NULL; i++)
-     MagickFreeMemory(commands[i]);
-   MagickFreeMemory(commands);
-Index: GraphicsMagick-1.3.7/magick/symbols.h
-===================================================================
---- GraphicsMagick-1.3.7.orig/magick/symbols.h
-+++ GraphicsMagick-1.3.7/magick/symbols.h
-@@ -29,6 +29,7 @@
- #define AcquireTemporaryFileDescriptor GmAcquireTemporaryFileDescriptor
- #define AcquireTemporaryFileName GmAcquireTemporaryFileName
- #define AcquireTemporaryFileStream GmAcquireTemporaryFileStream
-+#define AcquireTemporarySymlink GmAcquireTemporarySymlink
- #define AdaptiveThresholdImage GmAdaptiveThresholdImage
- #define AddDefinitions GmAddDefinitions
- #define AddNoiseImage GmAddNoiseImage
-Index: GraphicsMagick-1.3.7/magick/tempfile.c
-===================================================================
---- GraphicsMagick-1.3.7.orig/magick/tempfile.c
-+++ GraphicsMagick-1.3.7/magick/tempfile.c
-@@ -192,6 +192,93 @@ MagickExport MagickPassFail AcquireTempo
- %                                                                             %
- %                                                                             %
- %                                                                             %
-++   A c q u i r e T e m p o r a r y S y m l i n k                             %
-+%                                                                             %
-+%                                                                             %
-+%                                                                             %
-+%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
-+%
-+% AcquireTemporarySymlink replaces the contents of the string buffer pointed
-+% to by filename with the unique name of a symbolic link.  True is returned
-+% if a symlink waas created, or False is returned if there is a failure.
-+% The allocated symlink should be recovered via the LiberateTemporaryFile()
-+% function once it is no longer required.
-+%
-+% The format of the AcquireTemporarySymlink method is:
-+%
-+%     unsigned int AcquireTemporarySymlink(char *linkname, const char *name,
-+%                                          ExceptionInfo *exception)
-+%
-+%  A description of each parameter follows.
-+%
-+%   o linkname: Specifies a pointer to an array of characters that must be
-+%               MaxTextExtent characters of size.  The unique
-+%               name of the symlink is returned in this array.
-+%   o name: Specifies a file name the symlink should point to.
-+*/
-+MagickExport unsigned int AcquireTemporarySymlink(char *linkname, const char *name)
-+{
-+  char
-+    *tempdir,
-+    tempname[MaxTextExtent];
-+
-+  int
-+    fd,
-+    tries;
-+  
-+  assert(linkname != (char *)NULL);
-+  linkname[0]='\0';
-+  tempname[MaxTextExtent-1]='\0';
-+
-+  tempdir=getenv("MAGICK_TMPDIR");
-+#if defined(POSIX)
-+  if (!tempdir)
-+    tempdir=getenv("TMPDIR");
-+#endif /* POSIX */
-+#if defined(WIN32)
-+  if (!tempdir)
-+    tempdir=getenv("TMP");
-+  if (!tempdir)
-+    tempdir=getenv("TEMP");
-+#endif /* WIN32 */
-+#if defined(P_tmpdir)
-+  if (!tempdir)
-+    tempdir=P_tmpdir;
-+#endif
-+
-+  for (tries=0; tries < 15; tries++)
-+    {
-+      strncpy(tempname,"gmXXXXXX",MaxTextExtent-1);
-+      ComposeTemporaryFileName(tempname);
-+      strncpy(linkname,tempdir,MaxTextExtent-1);
-+      if (tempdir[strlen(tempdir)-1] != DirectorySeparator[0])
-+	strncat(linkname,DirectorySeparator,MaxTextExtent-1);
-+      strncat(linkname,tempname,MaxTextExtent-1);
-+      if (*name == '/')
-+        fd=symlink(name, linkname);
-+      else
-+        {
-+          char cname[MaxTextExtent];
-+	  if (!getcwd(cname,(size_t)MaxTextExtent))
-+	    return (False);
-+	  strncat(cname,DirectorySeparator,MaxTextExtent-1);
-+	  strncat(cname,name,MaxTextExtent-1);
-+	  fd=symlink(cname,linkname);
-+	}
-+      if (fd != -1)
-+	{
-+	  AddTemporaryFileToList(linkname);
-+	  return (True);
-+	}
-+    }
-+  return (False);
-+}
-+
-+/*
-+%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
-+%                                                                             %
-+%                                                                             %
-+%                                                                             %
- +   A c q u i r e T e m p o r a r y F i l e D e s c r i p t o r               %
- %                                                                             %
- %                                                                             %
-Index: GraphicsMagick-1.3.7/magick/tempfile.h
-===================================================================
---- GraphicsMagick-1.3.7.orig/magick/tempfile.h
-+++ GraphicsMagick-1.3.7/magick/tempfile.h
-@@ -26,6 +26,7 @@ MagickExport void
- 
- MagickExport MagickPassFail
-   AcquireTemporaryFileName(char *filename),
-+  AcquireTemporarySymlink(char *linkname, const char *name),
-   LiberateTemporaryFile(char *filename);
- 
- MagickExport int
-Index: GraphicsMagick-1.3.7/magick/utility.c
-===================================================================
---- GraphicsMagick-1.3.7.orig/magick/utility.c
-+++ GraphicsMagick-1.3.7/magick/utility.c
-@@ -1222,6 +1222,72 @@ MagickExport void FormatString(char *str
- %                                                                             %
- %                                                                             %
- %                                                                             %
-+%  F o r m a t S t r i n g N u m e r i c                                      %
-+%                                                                             %
-+%                                                                             %
-+%                                                                             %
-+%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
-+%
-+%  Method FormatStringNumeric formats output for a single numeric argument.
-+%  It takes into account that the format string given might be untrusted
-+%  user input, and returns a pointer to the formatted string.
-+%
-+%  The format of the FormatStringNumeric method is:
-+%
-+%      char * FormatStringNumeric(char *string,const char *format,int value)
-+%
-+%  A description of each parameter follows.
-+%
-+%   o  format:  A string describing the format to use to write the numeric
-+%      argument. Only the first numeric format identifier is replaced.
-+%
-+%   o  value:  Numeric value to substitute into format string.
-+%
-+%
-+*/
-+MagickExport char *FormatStringNumeric(const char *format,int value)
-+{
-+  char
-+    *p,
-+    *string;
-+
-+  string = NULL;
-+
-+  (void) CloneString(&string, format);
-+
-+  for (p=strchr(format,'%'); p != (char *) NULL; p=strchr(p+1,'%'))
-+  {  
-+    char
-+      *q;
-+
-+    q=(char *) p+1;
-+    if (*q == '0')
-+      (void) strtol(q,&q,10);
-+    if ((*q == '%') || (*q == 'd') || (*q == 'o') || (*q == 'x'))
-+    {
-+      char
-+        c;
-+
-+      q++;
-+      c=*q;
-+      *q='\0';
-+      (void) snprintf(string+(p-format),MaxTextExtent-(p-format),p,value);
-+      *q=c;
-+      (void) ConcatenateString(&string,q);
-+      if (*(q-1) == '%')
-+        p++;
-+      else
-+        break;
-+    }
-+  }
-+  return string;
-+}
-+
-+/*
-+%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
-+%                                                                             %
-+%                                                                             %
-+%                                                                             %
- %   G e t E x e c u t i o n P a t h                                           %
- %                                                                             %
- %                                                                             %
-Index: GraphicsMagick-1.3.7/magick/utility.h
-===================================================================
---- GraphicsMagick-1.3.7.orig/magick/utility.h
-+++ GraphicsMagick-1.3.7/magick/utility.h
-@@ -75,6 +75,7 @@ extern MagickExport char
-   *AllocateString(const char *),
-   *Base64Encode(const unsigned char *,const size_t,size_t *),
-   *EscapeString(const char *,const char),
-+  *FormatStringNumeric(const char *,int),
-   *GetPageGeometry(const char *),
-   **ListFiles(const char *,const char *,long *),
-   *SetClientName(const char *),
--- a/media-gfx/graphicsmagick/files/graphicsmagick-1.3.7-perl-ldflags.patch	Wed Mar 10 16:04:21 2010 +0100
+++ /dev/null	Thu Jan 01 00:00:00 1970 +0000
@@ -1,22 +0,0 @@
---- PerlMagick/Makefile.PL.in.orig	2010-01-10 20:05:53.000000000 +0000
-+++ PerlMagick/Makefile.PL.in	2010-01-10 23:27:53.000000000 +0000
-@@ -58,16 +58,16 @@
-    'LD'          => $Config{'ld'} == $Config{'cc'} ? '@CC@' : $Config{'ld'},
- 
-    # Linker flags for building an executable
--   'LDFLAGS'    =>  "-L@MAGICKLIBDIR@ $Config{'ldflags'}",
-+   'LDFLAGS'    =>  "$Config{'ldflags'} @LDFLAGS@",
- 
-    # Linker flags for building a dynamically loadable module
--   'LDDLFLAGS'  => "-L@MAGICKLIBDIR@ $Config{'lddlflags'}",
-+   'LDDLFLAGS'  => "$Config{'ldflags'} @LDFLAGS@ -L@MAGICKLIBDIR@ $Config{'lddlflags'}",
- 
-    # Install PerlMagick binary into GraphicsMagick bin directory
-    'INSTALLBIN'	=> '@BIN_DIR@',
- 
-    # Library specification
--   'LIBS'	=> ['-L@MAGICKLIBDIR@ -lGraphicsMagick @LDFLAGS@ @MAGICK_DEP_LIBS@'],
-+   'LIBS'	=> ['@LDFLAGS@ -L@MAGICKLIBDIR@ -lGraphicsMagick @MAGICK_DEP_LIBS@'],
- 
-    # Perl binary name (if a Perl binary is built)
-    'MAP_TARGET'	=> 'PerlMagick',
--- a/media-gfx/graphicsmagick/graphicsmagick-1.3.12.ebuild	Wed Mar 10 16:04:21 2010 +0100
+++ /dev/null	Thu Jan 01 00:00:00 1970 +0000
@@ -1,126 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/graphicsmagick/graphicsmagick-1.3.11.ebuild,v 1.2 2010/02/25 04:18:23 bicatali Exp $
-
-EAPI="2"
-
-inherit eutils toolchain-funcs flag-o-matic perl-module
-
-MY_P=${P/graphicsm/GraphicsM}
-
-DESCRIPTION="Collection of tools and libraries for many image formats"
-HOMEPAGE="http://www.graphicsmagick.org/"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE="bzip2 cxx debug doc fpx imagemagick jbig jpeg jpeg2k lcms openmp
-	perl png q16 q32 svg threads tiff truetype X wmf zlib"
-
-RDEPEND="app-text/ghostscript-gpl
-	bzip2? ( app-arch/bzip2 )
-	fpx? ( media-libs/libfpx )
-	jbig? ( media-libs/jbigkit )
-	jpeg? ( media-libs/jpeg )
-	jpeg2k? ( >=media-libs/jasper-1.701.0 )
-	lcms? ( media-libs/lcms )
-	perl? ( dev-lang/perl )
-	png? ( media-libs/libpng )
-	svg? ( dev-libs/libxml2 )
-	tiff? ( >=media-libs/tiff-3.8.2 )
-	truetype? ( >=media-libs/freetype-2.0 )
-	wmf? ( media-libs/libwmf )
-	X? ( x11-libs/libXext x11-libs/libSM )
-	imagemagick? ( !media-gfx/imagemagick )"
-
-DEPEND="${RDEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-pkg_setup() {
-	if use openmp &&
-		[[ $(tc-getCC)$ == *gcc* ]] &&
-		( [[ $(gcc-major-version)$(gcc-minor-version) -lt 42 ]] ||
-			! has_version sys-devel/gcc[openmp] )
-	then
-		ewarn "You are using gcc and OpenMP is only available with gcc >= 4.2 "
-		ewarn "If you want to build fftw with OpenMP, abort now,"
-		ewarn "and switch CC to an OpenMP capable compiler"
-		epause 5
-	fi
-}
-
-src_prepare() {
-	epatch "${FILESDIR}/${PN}-1.3.7-perl-ldflags.patch"
-	epatch "${FILESDIR}/${PN}-1.3.7-debian-fixed.patch"
-}
-
-src_configure() {
-	local quantumDepth
-	if use q16 ; then
-		quantumDepth="16"
-	elif use q32 ; then
-		quantumDepth="32"
-	else
-		quantumDepth="8"
-	fi
-
-	use debug && filter-flags -fomit-frame-pointer
-	econf \
-		--docdir=/usr/share/doc/${PF} \
-		--htmldir=/usr/share/doc/${PF}/html \
-		--enable-shared \
-		--enable-largefile \
-		--without-included-ltdl \
-		--without-frozenpaths \
-		--without-gslib \
-		--with-modules \
-		--with-quantum-depth=${quantumDepth} \
-		--with-fontpath="/usr/share/fonts" \
-		--with-gs-font-dir="/usr/share/fonts/default/ghostscript" \
-		--with-windows-font-dir="/usr/share/fonts/corefonts" \
-		$(use_enable debug ccmalloc) \
-		$(use_enable debug prof) \
-		$(use_enable debug gcov) \
-		$(use_enable imagemagick magick-compat) \
-		$(use_enable openmp) \
-		$(use_with bzip2 bzlib) \
-		$(use_with cxx magick-plus-plus) \
-		$(use_with fpx) \
-		$(use_with jbig) \
-		$(use_with jpeg) \
-		$(use_with jpeg2k jp2) \
-		$(use_with lcms) \
-		$(use_with perl) \
-		$(use_with png) \
-		$(use_with svg xml) \
-		$(use_with threads) \
-		$(use_with tiff) \
-		$(use_with truetype ttf) \
-		$(use_with wmf) \
-		$(use_with X x) \
-		$(use_with zlib)
-}
-
-src_compile() {
-	emake || die "emake failed"
-	if use perl; then
-		emake perl-build || die "emake perl failed"
-	fi
-}
-
-src_test() {
-	emake check || die "tests failed"
-}
-
-src_install() {
-	emake DESTDIR="${D}" install || die "emake install failed"
-	if use perl; then
-		perl -MExtUtils::MakeMaker -e 'MY->fixin(@ARGV)' PerlMagick/demo/*.pl
-		emake -C PerlMagick DESTDIR="${D}" \
-			install || die "emake perl install failed"
-		fixlocalpod
-	fi
-	use doc || rm -rf "${D}"usr/share/doc/${PF}/html
-}
--- a/media-gfx/graphicsmagick/metadata.xml	Wed Mar 10 16:04:21 2010 +0100
+++ /dev/null	Thu Jan 01 00:00:00 1970 +0000
@@ -1,26 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<maintainer>
-  <email>bicatali@gentoo.org</email>
-  <description>
-    Not really a maitainer, just helping out. Feel free to do anything
-    with the package.
-  </description>
-</maintainer>
-<herd>graphics</herd>
-<longdescription lang='en'>
-  This is a port of GraphicsMagick(TM), the "swiss army knife" of
-  image processing. It provides a robust collection of tools and libraries
-  which support reading, writing, and manipulating an image in over 88 major
-  formats including formats like DPX, GIF, JPEG, JPEG-2000, PNG, PDF,
-  SVG and TIFF.
-  The program is the fork of a better-known ImageMagick (5.5.2), which
-  emphasizes end-user and API-stabilities.
-</longdescription>
-<use>
-  <flag name='fpx'>Enable FlashPix support</flag>
-  <flag name='q16'>Set quantum depth to 16</flag>
-  <flag name='q32'>Set quantum depth to 32</flag>
-</use>
-</pkgmetadata>