changeset 563:36907de785d6

pygments in main portage is newer
author Dirk Olmes <dirk.olmes@codedo.de>
date Fri, 16 Dec 2022 07:48:31 +0100
parents 6af40b737a1c
children fdae90d4ff68
files dev-python/pygments/Manifest dev-python/pygments/pygments-2.1.3.ebuild
diffstat 2 files changed, 0 insertions(+), 54 deletions(-) [+]
line wrap: on
line diff
--- a/dev-python/pygments/Manifest	Thu Nov 10 08:00:43 2022 +0100
+++ /dev/null	Thu Jan 01 00:00:00 1970 +0000
@@ -1,2 +0,0 @@
-DIST Pygments-2.1.3.tar.gz 2116434 SHA256 88e4c8a91b2af5962bfa5ea2447ec6dd357018e86e94c7d14bd8cacbc5b55d81 SHA512 f6885abfa0033dc2b8894649c7a4626165af01e69268344f002efdfc536c776a9af86be4e76e5905bd31cb78096e1ed3c16d9dd4b29c6a97b4c9cc1bfd7a5b67 WHIRLPOOL c2315b8be55adc65f48675e58f946af6bf2118661beb0ab7ac149325a2d7f7b19aedef7b1ea6e070b5405c80c3b212cbe520ef23969bffb63bee1d7d6f589f41
-EBUILD pygments-2.1.3.ebuild 1686 SHA256 b72025591746063f42eb113c1a4db6b38bf7cffd9165f1669e90f5aae0ddc1fa SHA512 63044bd3ebc5de282da567f394bb2065fdcbe0553cf734e01672d01e945bcd746691254977c4a5d23cd0591be140c79d37502ed12c6ac60b137279cf0bf074ce WHIRLPOOL 9d87af0c23ea362a0ce3331a18d53978252346f8413fd3b1422e99c5a058c807133b6f29a4860abb19ea76ddaf1544f6dc1aa764ad73c7ca0c26e514694f0bf7
--- a/dev-python/pygments/pygments-2.1.3.ebuild	Thu Nov 10 08:00:43 2022 +0100
+++ /dev/null	Thu Jan 01 00:00:00 1970 +0000
@@ -1,52 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
-
-inherit distutils-r1 bash-completion-r1 vcs-snapshot
-
-MY_PN="Pygments"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Pygments is a syntax highlighting package written in Python"
-HOMEPAGE="http://pygments.org/ https://pypi.python.org/pypi/Pygments"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="doc test"
-
-RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
-	doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
-	test? (
-		dev-python/nose[${PYTHON_USEDEP}]
-		virtual/ttf-fonts )"
-#		dev-texlive/texlive-latexrecommended
-# Removing / commenting out this dep. I can find no mention of it in tests other than
-# importing pygment's own tex module.  If it's there and I missed it just uncomment and re-add
-# Tests pass without it
-
-S="${WORKDIR}/${MY_P}"
-
-python_compile_all() {
-	use doc && emake -C doc html
-}
-
-python_test() {
-	cp -r -l tests "${BUILD_DIR}"/ || die
-	# With pypy3 there is 1 error out of 1556 tests when run as is and
-	# (SKIP=8, errors=1, failures=1) when run with 2to3; meh
-	nosetests --verbosity=3 -w "${BUILD_DIR}"/tests \
-		|| die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
-	use doc && local HTML_DOCS=( doc/_build/html/. )
-
-	distutils-r1_python_install_all
-	newbashcomp external/pygments.bashcomp pygmentize
-}