changeset 468:452cbe2f0c48

update for the psi-plus ebuild
author Dirk Olmes <dirk@xanthippe.ping.de>
date Sat, 02 Mar 2019 07:32:01 +0100
parents bbe82f34a9fb
children ce3ab8337610
files net-im/psi-plus/Manifest net-im/psi-plus/psi-plus-1.4.574.ebuild
diffstat 2 files changed, 144 insertions(+), 0 deletions(-) [+]
line wrap: on
line diff
--- a/net-im/psi-plus/Manifest	Tue Feb 26 01:31:30 2019 +0100
+++ b/net-im/psi-plus/Manifest	Sat Mar 02 07:32:01 2019 +0100
@@ -1,3 +1,5 @@
 AUX qmake.patch 2010 BLAKE2B 824db6d67e8c7a80d320631f9f148f8903b42ff4ee8cd4403f4ee60e7ee66b5003504f0841563d74e36aaee63b5261ea3b9f35365624e07e85eff8253acbc848 SHA512 8f8aaef67c10d0c7ca1fd7c2c3123258b5b5785b7dc5eb2a2c7d8667048ec209cf61c26eb5f51c5547a7204b976103bf992c345814576191b26f7766e5162b98
 DIST psi-plus-1.2.109.tar.gz 8575286 BLAKE2B 431ab89cbc898c932113a7ed2942a712684b039b422ce80fce74a45385e49860b96303ac0e72a32dc4f8d564cbf0bd9a0718cdc46e319ab34875b79109dc5359 SHA512 fd6b41e2b50b15179da9f7c81ed39e2ad4d7dacfd50385cd5220f9357d277d42afc57dfd4ccedb18405af0b254def69458e7d6907fc286861f6d40a59b2ad83e
+DIST psi-plus-1.4.574.tar.gz 9012361 BLAKE2B deb4d460ea548d7c1145b0f8df90ddd303ebc55c9b7a20d33475f9a1925e858a4de06ace6692aa9616d48f76cf2b4f681122319dc730fc33333fe125ac073ce2 SHA512 eb37f8658a7231afc47a6d0670dea6d4d247ed9d938f815d8676ecb8b9805c9e2ac1870df09a53437268c343657f30588f635ec5b78104b1aa8bf7f35b35df0e
 EBUILD psi-plus-1.2.109.ebuild 2998 BLAKE2B 1d26e4562a71d2c99ccd4a033e9d3c012219ae41699cca33a344af6115767906f6f8e8f828fbe94f61c8a4759fe4966f518f9411920b60c67136d436dd526622 SHA512 5e8a2dad33c19ac3f726afdf2ed60bf02871333010d2641490ebd1bd4f349ff03ea22f97b7a85997ec3c061c95664e3948be24be202e1fe5f63784dc8cafa68b
+EBUILD psi-plus-1.4.574.ebuild 2988 BLAKE2B becf46b72a4e0b63050e963d3a7cf847d829322caf8378fb521fa083c0cd55b6faec3c0ff5c000640804108296e6f39ab5562b69518eeddedfcbad3a5be476b5 SHA512 0f578e1e811abbcccabbf1393a37e9b030a5c12b0cf9bf1a1e173c784fb9a5bdd0dc73efde10b0d3e53ea9eb3c492b7e2b4296fcabcd9a650662525671d4952a
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/net-im/psi-plus/psi-plus-1.4.574.ebuild	Sat Mar 02 07:32:01 2019 +0100
@@ -0,0 +1,142 @@
+
+EAPI=5
+
+inherit eutils l10n multilib gnome2-utils
+
+DESCRIPTION="Qt5 Jabber client, with Licq-like interface"
+HOMEPAGE="https://github.com/psi-plus/psi-plus-snapshots/"
+SRC_URI="https://github.com/psi-plus/psi-plus-snapshots/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+S="${WORKDIR}/psi-plus-snapshots-${PV}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="autoreplyplugin crypt dbus debug doc jingle otrplugin spell ssl xscreensaver watcherplugin whiteboarding"
+#RESTRICT="test"
+
+RDEPEND="app-arch/unzip
+	dev-qt/qtgui:5
+	>=app-crypt/qca-2.1.3:2[qt5(+)]
+	x11-libs/libX11
+	dbus? ( dev-qt/qtdbus:5 )
+	spell? ( >=app-text/enchant-1.3.0 )
+	xscreensaver? ( x11-libs/libXScrnSaver )
+	whiteboarding? ( dev-qt/qtsvg:5 )
+	|| ( >=sys-libs/zlib-1.2.5.1-r2[minizip] <sys-libs/zlib-1.2.5.1-r1 )"
+
+DEPEND="${RDEPEND}
+	sys-devel/qconf
+	doc? ( app-doc/doxygen )"
+
+PDEPEND="crypt? ( app-crypt/qca:2[gpg] )
+	jingle? ( net-im/psimedia
+	app-crypt/qca:2[ssl] )
+	ssl? ( app-crypt/qca:2[ssl] )
+	otrplugin? ( net-libs/libotr app-text/htmltidy )"
+
+src_prepare() {
+	epatch_user
+}
+
+src_configure() {
+	# unable to use econf because of non-standard configure script
+	local confcmd="./configure
+		--qtselect=5
+		--prefix=/usr
+		--datadir=/usr/share
+		--libdir=/usr/lib64
+		--disable-growl
+		--with-qca-inc=/usr/include/QtCrypto
+		--with-qca-lib=/usr/lib64
+		$(use dbus || echo '--disable-qdbus')
+		$(use debug && echo '--debug')
+		$(use spell || echo '--disable-aspell')
+		$(use spell || echo '--disable-enchant')
+		$(use xscreensaver || echo '--disable-xss')
+		$(use whiteboarding && echo '--enable-whiteboarding')"
+
+	echo ${confcmd}
+	${confcmd} || die "configure failed"
+	## Makefile is not always created...
+	#[[ ! -f Makefile ]] && die "configure failed"
+}
+
+src_compile() {
+	emake || die "emake failed"
+	
+	if use autoreplyplugin; then
+		cd src/plugins/generic/autoreplyplugin
+		qmake
+		make
+		cd ../../../..
+	fi
+
+	if use otrplugin; then
+		cd src/plugins/generic/otrplugin
+		qmake
+		make
+		cd ../../../..
+	fi
+	
+	if use watcherplugin; then
+		cd src/plugins/generic/watcherplugin
+		qmake
+		make
+		cd ../../../..
+	fi
+}
+
+src_install() {
+	emake DESTDIR="${D}" INSTALL_ROOT="${D}" install
+	dodoc README TODO
+	
+	local plugindir="/usr/share/psi-plus/plugins"
+	if use autoreplyplugin; then
+		cd src/plugins/generic/autoreplyplugin
+
+		strip --strip-unneeded libautoreplyplugin.so
+
+		dodir "${plugindir}"
+		insinto "${plugindir}"
+		doins libautoreplyplugin.so
+
+		cd ../../../..
+	fi
+
+	if use otrplugin; then
+		cd src/plugins/generic/otrplugin
+
+		strip --strip-unneeded libotrplugin.so
+
+		dodir "${plugindir}"
+		insinto "${plugindir}"
+		doins libotrplugin.so
+
+		cd ../../../..
+	fi
+
+	if use watcherplugin; then
+		cd src/plugins/generic/watcherplugin
+
+		strip --strip-unneeded libwatcherplugin.so
+
+		dodir "${plugindir}"
+		insinto "${plugindir}"
+		doins libwatcherplugin.so
+
+		cd ../../../..
+	fi
+}
+
+pkg_preinst() {
+	gnome2_icon_savelist
+}
+
+pkg_postinst() {
+	gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+	gnome2_icon_cache_update
+}