changeset 431:4b67abbaacee

add dependency on gmpy
author Dirk Olmes <dirk@xanthippe.ping.de>
date Sat, 03 Dec 2016 06:05:41 +0100
parents 71a79165eb75
children 8b06995f9f2a
files dev-python/potr/Manifest dev-python/potr/potr-1.2.0.ebuild
diffstat 2 files changed, 6 insertions(+), 3 deletions(-) [+]
line wrap: on
line diff
--- a/dev-python/potr/Manifest	Sat Dec 03 05:40:08 2016 +0100
+++ b/dev-python/potr/Manifest	Sat Dec 03 06:05:41 2016 +0100
@@ -1,2 +1,2 @@
 DIST potr-1.2.0.tar.gz 21440 SHA256 df17b17e5d56dc472d59c59190951ddb67952a0ac02cb4fd64ccbef9b211f790 SHA512 45326b3cb1f02eca0cc96d545c862acc87c25e0f1d3f0146bae51953fccba485b264b89143b4d00b9f8f9133c2811dee6dc255c7ebb2375ed70bd49a2feb1f71 WHIRLPOOL 0ab2a8894c8df10f225dc6ca604cbdd03c1f375c510c21368d290603fd4da7178e872604e3544d1cb3b2b23b4bc2a751c5a5231b1854d74d57f495c7c10ac3bf
-EBUILD potr-1.2.0.ebuild 652 SHA256 f3fd0872577f594839715735e64263046afad030cc5f00f5c36bac55808fcdc1 SHA512 091281df92d454507454e428fa5ec7c9296dd4bda58b7b3bb48fc5fe4954224f94c92e49c1a05831167334b1fd4c06af8a57b8f8361257d2658f60666cfb98f4 WHIRLPOOL 43928e396cc40fb2732d8dfddba13a0b4fa7e940f8bbc57c85ab47bfd0e8eac6d5574a85b4d576f5e8234ebd275cc674b15f955c93a0878913ba5843ab3a9eb2
+EBUILD potr-1.2.0.ebuild 739 SHA256 f7bda54a57bc62eda87c4602a5c56b6c6ad6e5735e3633a2ffc73592dea01d9e SHA512 1af15e15bd28153ddca098cbc66a3828756fa7350646659c89a75515f4631d01689ac7d864a90b9ae6e1e5c8192db9b4aa38cdcc0451700409bc942587813262 WHIRLPOOL 2cff9eb47ee3a9c15295b2a002b3ea67de9440c187ddf86818ab55aadbabbfaac49a061478fc8f09cfcc68805aa4246c43abb7a5c1dbe0bdbaea59fe992e1c26
--- a/dev-python/potr/potr-1.2.0.ebuild	Sat Dec 03 05:40:08 2016 +0100
+++ b/dev-python/potr/potr-1.2.0.ebuild	Sat Dec 03 06:05:41 2016 +0100
@@ -6,7 +6,8 @@
 
 MY_P="python-otr-release-${PV}"
 
-#PYTHON_COMPAT=( python{2_7,3_4} )
+# compile errors with python3 ... skip for now
+#PYTHON_COMPAT=( python2_7 python3_4 )
 PYTHON_COMPAT=( python2_7 )
 
 inherit distutils-r1
@@ -20,7 +21,9 @@
 KEYWORDS="~amd64"
 IUSE=""
 
-CDEPEND=">=dev-python/pycrypto-2.1[${PYTHON_USEDEP}]"
+CDEPEND=">=dev-python/pycrypto-2.1[${PYTHON_USEDEP}]
+	dev-python/gmpy[${PYTHON_USEDEP}]
+"
 DEPEND="${CDEPEND}
 	dev-python/setuptools[${PYTHON_USEDEP}]
 	"