changeset 265:4f80c1679ba4

add fixed ossp-uuid
author holger
date Fri, 19 Nov 2010 17:39:31 +0100
parents a62b22eecde5
children f85cecd684fc
files dev-libs/ossp-uuid/Manifest dev-libs/ossp-uuid/files/ossp-uuid-1.6.2-gentoo.patch dev-libs/ossp-uuid/ossp-uuid-1.6.2.ebuild
diffstat 3 files changed, 198 insertions(+), 0 deletions(-) [+]
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/dev-libs/ossp-uuid/Manifest	Fri Nov 19 17:39:31 2010 +0100
@@ -0,0 +1,3 @@
+AUX ossp-uuid-1.6.2-gentoo.patch 4777 RMD160 ce76189a2bcb1d4b1e9293a6c1be39ce6327d4b3 SHA1 0a64f4b85b9c3433ec5ae09aede129040cca4771 SHA256 4b51299cab73dec10500b2114a5993532a6358686c643d5ae9b9d7e7ff0e211c
+DIST uuid-1.6.2.tar.gz 397048 RMD160 f9cd513577557c4f1d7de869f80035b8844b56d7 SHA1 3e22126f0842073f4ea6a50b1f59dcb9d094719f SHA256 11a615225baa5f8bb686824423f50e4427acd3f70d394765bdff32801f0fd5b0
+EBUILD ossp-uuid-1.6.2.ebuild 1984 RMD160 ab294b1c1f1105c663568a62b23de7e6e0e29912 SHA1 499ca5f980660388e5012bb4266b03d252cafd50 SHA256 f48710ec66007aa5780584f33a10f15d08ff76a497967f9d435b40cee68eda8a
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/dev-libs/ossp-uuid/files/ossp-uuid-1.6.2-gentoo.patch	Fri Nov 19 17:39:31 2010 +0100
@@ -0,0 +1,113 @@
+diff -Naur uuid-1.6.2.orig/Makefile.in uuid-1.6.2/Makefile.in
+--- uuid-1.6.2.orig/Makefile.in	2009-03-21 12:52:49.142847389 +0100
++++ uuid-1.6.2/Makefile.in	2009-03-21 12:53:54.201971177 +0100
+@@ -62,13 +62,13 @@
+ PHP         = @PHP@
+ PG_CONFIG   = @PG_CONFIG@
+ 
+-LIB_NAME    = libuuid.la
++LIB_NAME    = libossp-uuid.la
+ LIB_OBJS    = uuid.lo uuid_md5.lo uuid_sha1.lo uuid_prng.lo uuid_mac.lo uuid_time.lo uuid_ui64.lo uuid_ui128.lo uuid_str.lo
+ 
+-DCE_NAME    = libuuid_dce.la
++DCE_NAME    = libossp-uuid_dce.la
+ DCE_OBJS    = uuid_dce.lo $(LIB_OBJS)
+ 
+-CXX_NAME    = libuuid++.la
++CXX_NAME    = libossp-uuid++.la
+ CXX_OBJS    = uuid++.lo $(LIB_OBJS)
+ 
+ PRG_NAME    = uuid
+@@ -112,15 +112,15 @@
+ 	@$(LIBTOOL) --mode=compile $(CXX) $(CPPFLAGS) $(CXXFLAGS) -c $<
+ 
+ $(LIB_NAME): $(LIB_OBJS)
+-	@$(LIBTOOL) --mode=link $(CC) -o $(LIB_NAME) $(LIB_OBJS) -rpath $(libdir) \
++	@$(LIBTOOL) --mode=link $(CC) $(LDFLAGS) -o $(LIB_NAME) $(LIB_OBJS) -rpath $(libdir) \
+ 	    -version-info `$(SHTOOL) version -l c -d libtool $(S)/uuid_vers.h`
+ 
+ $(DCE_NAME): $(DCE_OBJS)
+-	@$(LIBTOOL) --mode=link $(CC) -o $(DCE_NAME) $(DCE_OBJS) -rpath $(libdir) \
++	@$(LIBTOOL) --mode=link $(CC) $(LDFLAGS) -o $(DCE_NAME) $(DCE_OBJS) -rpath $(libdir) \
+ 	    -version-info `$(SHTOOL) version -l c -d libtool $(S)/uuid_vers.h`
+ 
+ $(CXX_NAME): $(CXX_OBJS)
+-	@$(LIBTOOL) --mode=link $(CXX) -o $(CXX_NAME) $(CXX_OBJS) -rpath $(libdir) \
++	@$(LIBTOOL) --mode=link $(CXX) $(LDFLAGS) -o $(CXX_NAME) $(CXX_OBJS) -rpath $(libdir) \
+ 	    -version-info `$(SHTOOL) version -l c -d libtool $(S)/uuid_vers.h`
+ 
+ $(PRG_NAME): $(PRG_OBJS) $(LIB_NAME)
+@@ -253,7 +253,7 @@
+ 	-@if [ ".$(WITH_CXX)" = .yes ]; then \
+ 	    $(LIBTOOL) --mode=install $(SHTOOL) install -c -m 644 $(CXX_NAME) $(DESTDIR)$(libdir)/; \
+ 	fi
+-	@$(LIBTOOL) --mode=install $(SHTOOL) install -c -s -m 755 uuid $(DESTDIR)$(bindir)/
++	@$(LIBTOOL) --mode=install $(SHTOOL) install -c -m 755 uuid $(DESTDIR)$(bindir)/
+ 	$(SHTOOL) install -c -m 644 $(S)/uuid.1 $(DESTDIR)$(mandir)/man1/
+ 	-@if [ ".$(WITH_PERL)" = .yes ]; then \
+ 	    (cd $(S)/perl && $(MAKE) $(MFLAGS) install DESTDIR=$(DESTDIR)); \
+diff -Naur uuid-1.6.2.orig/php/config.m4 uuid-1.6.2/php/config.m4
+--- uuid-1.6.2.orig/php/config.m4	2009-03-21 12:52:49.142847389 +0100
++++ uuid-1.6.2/php/config.m4	2009-03-21 12:53:06.282809038 +0100
+@@ -33,10 +33,10 @@
+ if test "$PHP_UUID" != "no"; then
+     PHP_NEW_EXTENSION(uuid, uuid.c, $ext_shared)
+     AC_DEFINE(HAVE_UUID, 1, [Have OSSP uuid library])
+-    PHP_ADD_LIBPATH([..], )
+-    PHP_ADD_LIBRARY([uuid],, UUID_SHARED_LIBADD)
++    PHP_ADD_LIBRARY([ossp-uuid],, UUID_SHARED_LIBADD)
+     PHP_ADD_INCLUDE([..])
+     PHP_SUBST(UUID_SHARED_LIBADD)
++    LDFLAGS="$LDFLAGS -L../.libs"
+ 
+     dnl  avoid linking conflict with a potentially existing uuid_create(3) in libc
+     AC_CHECK_FUNC(uuid_create,[
+diff -Naur uuid-1.6.2.orig/php/Makefile.local uuid-1.6.2/php/Makefile.local
+--- uuid-1.6.2.orig/php/Makefile.local	2009-03-21 12:52:49.142847389 +0100
++++ uuid-1.6.2/php/Makefile.local	2009-03-21 12:53:06.282809038 +0100
+@@ -42,7 +42,7 @@
+ 
+ test: build
+ 	@version=`$(PHP)-config --version | sed -e 's;^\([0-9]\).*$$;\1;'`; \
+-	$(PHP) -q -d "safe_mode=0" -d "extension_dir=./" uuid.ts $$version
++	$(PHP) -q -d "safe_mode=0" -d "extension_dir=./modules/" uuid.ts $$version
+ 
+ install: build
+ 	@version=`$(PHP)-config --version | sed -e 's;^\([0-9]\).*$$;\1;'`; extdir="$(EXTDIR)"; \
+diff -Naur uuid-1.6.2.orig/php/uuid.ts uuid-1.6.2/php/uuid.ts
+--- uuid-1.6.2.orig/php/uuid.ts	2009-03-21 12:52:49.142847389 +0100
++++ uuid-1.6.2/php/uuid.ts	2009-03-21 12:53:06.282809038 +0100
+@@ -36,7 +36,7 @@
+ 
+ print "++ loading DSO uuid.so (low-level API)\n";
+ if (!extension_loaded('uuid')) {
+-    dl('modules/uuid.so');
++    dl('uuid.so');
+ }
+ 
+ print "++ loading PHP uuid.php${php_version} (high-level API)\n";
+diff -Naur uuid-1.6.2.orig/uuid-config.in uuid-1.6.2/uuid-config.in
+--- uuid-1.6.2.orig/uuid-config.in	2009-03-21 12:52:49.146166177 +0100
++++ uuid-1.6.2/uuid-config.in	2009-03-21 12:53:06.282809038 +0100
+@@ -121,7 +121,7 @@
+             output_extra="$output_extra $uuid_ldflags"
+             ;;
+         --libs)
+-            output="$output -luuid"
++            output="$output -lossp-uuid"
+             output_extra="$output_extra $uuid_libs"
+             ;;
+         * )
+diff -Naur uuid-1.6.2.orig/uuid.pc.in uuid-1.6.2/uuid.pc.in
+--- uuid-1.6.2.orig/uuid.pc.in	2009-03-21 12:52:49.146166177 +0100
++++ uuid-1.6.2/uuid.pc.in	2009-03-21 12:53:06.282809038 +0100
+@@ -36,7 +36,7 @@
+ Description: Universally Unique Identifier (UUID) Library
+ Version: @UUID_VERSION_RAW@
+ URL: http://www.ossp.org/pkg/lib/uuid/
+-Cflags: -I${includedir}
+-Libs: -L${libdir} -luuid
++Cflags: -I${includedir}/ossp
++Libs: -L${libdir} -lossp-uuid
+ Libs.private: @LIBS@
+ 
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/dev-libs/ossp-uuid/ossp-uuid-1.6.2.ebuild	Fri Nov 19 17:39:31 2010 +0100
@@ -0,0 +1,82 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/ossp-uuid/ossp-uuid-1.6.2.ebuild,v 1.8 2010/04/25 20:14:06 armin76 Exp $
+
+EAPI="2"
+
+PHP_EXT_NAME="uuid"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+PHP_VERSION="5"
+
+inherit eutils multilib php-ext-source-r2 depend.php
+
+MY_P="uuid-${PV}"
+
+DESCRIPTION="An ISO-C:1999 API and corresponding CLI for the generation of DCE 1.1, ISO/IEC 11578:1996 and RFC 4122 compliant UUID."
+HOMEPAGE="http://www.ossp.org/pkg/lib/uuid/"
+SRC_URI="ftp://ftp.ossp.org/pkg/lib/uuid/${MY_P}.tar.gz"
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="+cxx php"
+
+DEPEND="php? ( dev-lang/php:5.3 )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+	unpack ${A}
+	cd "${S}"
+
+	epatch "${FILESDIR}/${P}-gentoo.patch"
+
+	if use php; then
+		cd php
+		php-ext-source-r2_phpize
+	fi
+}
+
+src_compile() {
+	# Notes:
+	# * collides with e2fstools libs and includes if not moved around
+	# * perl-bindings are broken
+	# * pgsql-bindings need PostgreSQL-sources and are included since PostgreSQL 8.3
+	econf \
+		--includedir=/usr/include/ossp \
+		--with-dce \
+		--without-pgsql \
+		--without-perl \
+		--without-php \
+		$(use_with cxx) \
+		|| die "econf failed"
+	emake || die "emake failed"
+
+	if use php; then
+		cd php
+		php-ext-source-r1_src_compile
+	fi
+}
+
+src_install() {
+	emake DESTDIR="${D}" install || die "emake install failed"
+
+	dodoc AUTHORS BINDINGS ChangeLog HISTORY NEWS OVERVIEW PORTING README SEEALSO THANKS TODO USERS
+
+	if use php ; then
+		cd php
+		php-ext-source-r1_src_install
+		insinto /usr/share/php5
+		newins uuid.php5 uuid.php
+	fi
+
+	mv "${D}/usr/$(get_libdir)/pkgconfig"/{,ossp-}uuid.pc
+	mv "${D}/usr/share/man/man3"/uuid.3{,ossp}
+	mv "${D}/usr/share/man/man3"/uuid++.3{,ossp}
+}
+
+src_test() {
+	emake check || die "emake check failed"
+	# Tests for the php-bindings would be available
+}