changeset 80:6da0c8668e7e

add TODOs, verify that initial install works
author holger@hoho.dyndns.org
date Tue, 14 Oct 2008 04:50:48 +0200
parents 7165b0bc5268
children aa44ff4f442e
files net-misc/zmq/Manifest net-misc/zmq/zmq-0.3.1.ebuild
diffstat 2 files changed, 16 insertions(+), 13 deletions(-) [+]
line wrap: on
line diff
--- a/net-misc/zmq/Manifest	Mon Oct 13 19:00:52 2008 +0200
+++ b/net-misc/zmq/Manifest	Tue Oct 14 04:50:48 2008 +0200
@@ -1,3 +1,3 @@
 DIST zmq-0.3.1.tar.gz 465330 RMD160 7abb2077624e5fc5b05a4b25a2eb5b2a530c6fe4 SHA1 feea7376ffec235916eac11e330d209ddd3f1417 SHA256 213a9fdc10b382ffb61426ddb12abd7fa2c4de0d7510b42352b3c495c1bfe234
-EBUILD zmq-0.3.1.ebuild 847 RMD160 08529d8d8941057e9a35779b4e84442fdeabeff3 SHA1 89cc97a8de900888a35cabae25b38146e04d69bf SHA256 543d7cc0f7c7ab48a040224cf4fe59dfe965587306d4196088738ab9b7dda84f
-MISC zmq-0.3.1.ebuild~ 852 RMD160 21c20e9badf32fc18824227e40ee4f84bcf6137a SHA1 d267ac6a684a50104cd962f9251e82a8f14c51e1 SHA256 04ead169d0b8e1be9429f6a7ab10a663c683192dd6f56cd859a54db24e209afe
+EBUILD zmq-0.3.1.ebuild 1042 RMD160 f9eae30c1f712baa77a8849fad3069692a33f00b SHA1 ddedbd9c7c2c46c0945ce6d88f6b77f69b9e14ca SHA256 353f16d6e58d6e183ee3b13861636db89b916e4cd7ebb6974542af14878dfdb0
+MISC zmq-0.3.1.ebuild~ 847 RMD160 08529d8d8941057e9a35779b4e84442fdeabeff3 SHA1 89cc97a8de900888a35cabae25b38146e04d69bf SHA256 543d7cc0f7c7ab48a040224cf4fe59dfe965587306d4196088738ab9b7dda84f
--- a/net-misc/zmq/zmq-0.3.1.ebuild	Mon Oct 13 19:00:52 2008 +0200
+++ b/net-misc/zmq/zmq-0.3.1.ebuild	Tue Oct 14 04:50:48 2008 +0200
@@ -10,19 +10,22 @@
 LICENSE="LGPL-3"
 SLOT="0"
 KEYWORDS="~x86"
-IUSE="c java python profile"
-
-DEPEND=""
-RDEPEND="${DEPEND}"
-
-# Source directory; the dir where the sources can be found (automatically
-# unpacked) inside ${WORKDIR}.  The default value for S is ${WORKDIR}/${P}
-# If you don't need to change it, leave the S= line out of the ebuild
-# to keep it tidy.
-#S="${WORKDIR}/${P}"
+#IUSE="c examples java profile python"
+#DEPEND=""
+#RDEPEND="${DEPEND}"
 
 src_compile() {
-	econf || die "econf failed"
+
+# TODO:
+#  --with-perf             build performance tests [default=no]
+#  --with-camera           build camera example [default=no]
+#  --with-exchange         build exchange example [default=no]
+#  --with-chat             build chatroom example [default=no]
+#  --with-c                build c language binding [default=no]
+#  --with-python           build Python language binding [default=no]
+#  --with-java             build Java language binding [default=no]
+
+	econf \
 	emake || die "emake failed"
 }