changeset 79:7165b0bc5268

initial import of zeromq ebuild
author holger@hoho.dyndns.org
date Mon, 13 Oct 2008 19:00:52 +0200
parents 47db27a12ba2
children 6da0c8668e7e
files net-misc/zmq/Manifest net-misc/zmq/zmq-0.3.1.ebuild
diffstat 2 files changed, 34 insertions(+), 0 deletions(-) [+]
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/net-misc/zmq/Manifest	Mon Oct 13 19:00:52 2008 +0200
@@ -0,0 +1,3 @@
+DIST zmq-0.3.1.tar.gz 465330 RMD160 7abb2077624e5fc5b05a4b25a2eb5b2a530c6fe4 SHA1 feea7376ffec235916eac11e330d209ddd3f1417 SHA256 213a9fdc10b382ffb61426ddb12abd7fa2c4de0d7510b42352b3c495c1bfe234
+EBUILD zmq-0.3.1.ebuild 847 RMD160 08529d8d8941057e9a35779b4e84442fdeabeff3 SHA1 89cc97a8de900888a35cabae25b38146e04d69bf SHA256 543d7cc0f7c7ab48a040224cf4fe59dfe965587306d4196088738ab9b7dda84f
+MISC zmq-0.3.1.ebuild~ 852 RMD160 21c20e9badf32fc18824227e40ee4f84bcf6137a SHA1 d267ac6a684a50104cd962f9251e82a8f14c51e1 SHA256 04ead169d0b8e1be9429f6a7ab10a663c683192dd6f56cd859a54db24e209afe
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/net-misc/zmq/zmq-0.3.1.ebuild	Mon Oct 13 19:00:52 2008 +0200
@@ -0,0 +1,31 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils
+
+DESCRIPTION="ZeroMQ is a brokerless messaging kernel with extremely high performance."
+HOMEPAGE="http://www.zeromq.org/"
+SRC_URI="http://www.zeromq.org/local--files/area:download/${P}.tar.gz"
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="c java python profile"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+# Source directory; the dir where the sources can be found (automatically
+# unpacked) inside ${WORKDIR}.  The default value for S is ${WORKDIR}/${P}
+# If you don't need to change it, leave the S= line out of the ebuild
+# to keep it tidy.
+#S="${WORKDIR}/${P}"
+
+src_compile() {
+	econf || die "econf failed"
+	emake || die "emake failed"
+}
+
+src_install() {
+	emake DESTDIR="${D}" install || die "emake install failed"
+}