changeset 408:757d9b59e20b

add an ebuild for the latest node version
author Dirk Olmes <dirk@xanthippe.ping.de>
date Sat, 09 Jan 2016 02:12:24 +0100
parents 0f4fd527fa00
children cb454e927ad1 06486d4a9de7
files net-libs/nodejs/Manifest net-libs/nodejs/nodejs-5.4.0.ebuild
diffstat 2 files changed, 158 insertions(+), 0 deletions(-) [+]
line wrap: on
line diff
--- a/net-libs/nodejs/Manifest	Wed Jan 06 08:40:49 2016 +0100
+++ b/net-libs/nodejs/Manifest	Sat Jan 09 02:12:24 2016 +0100
@@ -1,3 +1,5 @@
 AUX nodejs-ssl.patch 863 SHA256 2e4952286c145892b65091321b9ec5af88d2fb3114b3500ec78d7520a8952eb8 SHA512 23ebfe5c36f4f0998552c1a66eb8c3719990fa5dbd41d00cefdf65c0b598de29d1d88378c5600e7ea62997b13635b6fac59ec9a060e086acb453490cfda48569 WHIRLPOOL 289edc5d86b08bdc2987382907126bd6d0401d95e2ea207260bdcc7deee7a947d5ea6049efb1028af3619ab4c469392f58f52a183d85e3387fc68b9bbbe045c7
 DIST node-v0.12.7.tar.gz 20063992 SHA256 b23d64df051c9c969b0c583f802d5d71de342e53067127a5061415be7e12f39d SHA512 0c9cb7542530463e7703435c8d819949785c1c6497c6d98f9854ca615fe33a62f451833e856f0159b836a698b4dee5d165fa505bad5d474f664e1533090d8606 WHIRLPOOL 647391b8c49fda868c14bd4eb3089cac139f50e710ac6b141ea82e1013c4ff7d40cdb0e88d69604d06e3bd07775876c754211a2b099685cb7353ae5708812525
+DIST node-v5.4.0.tar.xz 12806256 SHA256 744a31979b7c48a9c605fbfa7c159fcd60732ce27061671fe03847ffe448a5a3 SHA512 86eab32434dd776eeff4a408912f866b1d2fee21a8c62f1ddcabcfd76c5aef6d8aca82afd57232980a40c2666fd2dc11654abe180dacc63d6f0da7dc4c3bb4a3 WHIRLPOOL 962f4879a548f236e80f626bee875f5a5040cf6d053d3d3d2ffde124aa1b768ca9a18f9efcdf64527da8c1c323c84fc347387d0f1ccd264bd68d3cbf36684e85
 EBUILD nodejs-0.12.7.ebuild 3488 SHA256 ba83a9bbf92a92a089183cdbfbaa37ceb2b9229c02b067e28466cb54921e5c3c SHA512 e6420cf39b4985b190af47d9aedd306f2691689cc562acbe7ee2578de15c5ed272db477199e9460efa78a072636fcaead307e6789ec311222066cd701f9f7311 WHIRLPOOL 8aac2d4ed1be172d0da0a52ad54d05b676bbf1b7bb16e5d6bd547249d8317beea6414ede16cb0bd538729ee7e44500041894f506a744d2e17acebb5e394eb1ee
+EBUILD nodejs-5.4.0.ebuild 4849 SHA256 c341353c210978621ee15630c4bfb35e20a04dba5c4db8a9df4b14c0408e7fbd SHA512 d2445a6d4d0dd9afd73892b4a51840d430d0b5a82683c3763423952962c335a5d1e5b56848cacbf3817e186d7a00f38472878e4a7e1fb6afe5284886e62ef2fe WHIRLPOOL d656eb42c9bd15e7f363b4c2e66b5bac391908a1115586b1c0b9b942004b4131943fb934e5dcf65babb9f57f96a6a475acf930b2ce7026f680d8065cf1bf57f7
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/net-libs/nodejs/nodejs-5.4.0.ebuild	Sat Jan 09 02:12:24 2016 +0100
@@ -0,0 +1,156 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit flag-o-matic pax-utils python-single-r1 toolchain-funcs
+
+DESCRIPTION="Evented IO for V8 Javascript"
+HOMEPAGE="http://nodejs.org/"
+SRC_URI="http://nodejs.org/dist/v${PV}/node-v${PV}.tar.xz"
+
+LICENSE="Apache-1.1 Apache-2.0 BSD BSD-2 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86 ~x64-macos"
+IUSE="debug icu +npm snapshot +ssl"
+
+RDEPEND="icu? ( >=dev-libs/icu-55:= )
+	${PYTHON_DEPS}
+	>=net-libs/http-parser-2.5:=
+	>=dev-libs/libuv-1.6.1:=
+	>=dev-libs/openssl-1.0.2d:0=[-bindist]
+	sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+	!!net-libs/iojs"
+
+S="${WORKDIR}/node-v${PV}"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+pkg_pretend() {
+	if [[ ${MERGE_TYPE} != "binary" ]] ; then
+		if ! test-flag-CXX -std=c++11 ; then
+			die "Your compiler doesn't support C++11. Use GCC 4.8, Clang 3.3 or newer."
+		fi
+	fi
+}
+
+src_prepare() {
+	tc-export CC CXX PKG_CONFIG
+	export V=1 # Verbose build
+	export BUILDTYPE=Release
+
+	# fix compilation on Darwin
+	# https://code.google.com/p/gyp/issues/detail?id=260
+	sed -i -e "/append('-arch/d" tools/gyp/pylib/gyp/xcode_emulation.py || die
+
+	# make sure we use python2.* while using gyp
+	sed -i -e "s/python/${EPYTHON}/" deps/npm/node_modules/node-gyp/gyp/gyp || die
+	sed -i -e "s/|| 'python'/|| '${EPYTHON}'/" deps/npm/node_modules/node-gyp/lib/configure.js || die
+
+	# less verbose install output (stating the same as portage, basically)
+	sed -i -e "/print/d" tools/install.py || die
+
+	# proper libdir, hat tip @ryanpcmcquen https://github.com/iojs/io.js/issues/504
+	local LIBDIR=$(get_libdir)
+	sed -i -e "s|lib/|${LIBDIR}/|g" tools/install.py || die
+	sed -i -e "s/'lib'/'${LIBDIR}'/" lib/module.js || die
+	sed -i -e "s|\"lib\"|\"${LIBDIR}\"|" deps/npm/lib/npm.js || die
+
+	# Avoid a test that I've only been able to reproduce from emerge. It doesnt
+	# seem sandbox related either (invoking it from a sandbox works fine).
+	# The issue is that no stdin handle is openened when asked for one.
+	# It doesn't really belong upstream , so it'll just be removed until someone
+	# with more gentoo-knowledge than me (jbergstroem) figures it out.
+	rm test/parallel/test-stdout-close-unref.js || die
+	# AssertionError: 1 == 2 (on line 97)
+	rm test/parallel/test-cluster-disconnect.js || die
+	# AssertionError: Client never errored
+	rm test/parallel/test-tls-hello-parser-failure.js || die
+	# --- TIMEOUT ---
+	rm test/parallel/test-child-process-fork-net.js \
+		test/parallel/test-child-process-fork-net2.js \
+		test/parallel/test-child-process-recv-handle.js \
+		test/parallel/test-cluster-dgram-1.js \
+		test/parallel/test-cluster-send-deadlock.js \
+		test/parallel/test-cluster-shared-handle-bind-error.js \
+		test/parallel/test-dgram-exclusive-implicit-bind.js \
+		test/parallel/test-tls-ticket-cluster.js || die
+
+	# debug builds. change install path, remove optimisations and override buildtype
+	if use debug; then
+		sed -i -e "s|out/Release/|out/Debug/|g" tools/install.py || die
+		BUILDTYPE=Debug
+	fi
+
+	epatch_user
+}
+
+src_configure() {
+	local myarch=""
+	local myconf+=( --shared-openssl --shared-libuv --shared-http-parser --shared-zlib )
+	use npm || myconf+=( --without-npm )
+	use icu && myconf+=( --with-intl=system-icu )
+	use snapshot && myconf+=( --with-snapshot )
+	use ssl || myconf+=( --without-ssl )
+	use debug && myconf+=( --debug )
+
+	case ${ABI} in
+		x86) myarch="ia32";;
+		amd64) myarch="x64";;
+		x32) myarch="x32";;
+		arm) myarch="arm";;
+		arm64) myarch="arm64";;
+		*) die "Unrecognized ARCH ${ARCH}";;
+	esac
+
+	GYP_DEFINES="linux_use_gold_flags=0
+		linux_use_bundled_binutils=0
+		linux_use_bundled_gold=0" \
+	"${PYTHON}" configure \
+		--prefix="${EPREFIX}"/usr \
+		--dest-cpu=${myarch} \
+		--without-dtrace \
+		"${myconf[@]}" || die
+}
+
+src_compile() {
+	emake -C out mksnapshot
+	pax-mark m "out/${BUILDTYPE}/mksnapshot"
+	emake -C out
+}
+
+src_install() {
+	local LIBDIR="${ED}/usr/$(get_libdir)"
+	emake install DESTDIR="${ED}" PREFIX=/usr
+	if use npm; then
+		dodoc -r "${LIBDIR}"/node_modules/npm/html
+		rm -rf "${LIBDIR}"/node_modules/npm/{doc,html} || die
+		find "${LIBDIR}"/node_modules -type f -name "LICENSE*" -or -name "LICENCE*" -delete || die
+	fi
+
+	# set up a symlink structure that npm expects..
+	dodir /usr/include/node/deps/{v8,uv}
+	dosym . /usr/include/node/src
+	for var in deps/{uv,v8}/include; do
+		dosym ../.. /usr/include/node/${var}
+	done
+
+	pax-mark -m "${ED}"/usr/bin/node
+}
+
+src_test() {
+	out/${BUILDTYPE}/cctest || die
+	declare -xl TESTTYPE="${BUILDTYPE}"
+	"${PYTHON}" tools/test.py --mode=${TESTTYPE} -J message parallel sequential || die
+}
+
+pkg_postinst() {
+	einfo "When using node-gyp to install native modules, you can avoid"
+	einfo "having to download the full tarball by doing the following:"
+	einfo ""
+	einfo "node-gyp --nodedir /usr/include/node <command>"
+}