changeset 228:a3c4bfaac1be

initial import of zookeeper
author holger
date Sun, 27 Jun 2010 22:50:34 +0200
parents 6783499b0247
children 8195e324dc22
files sys-cluster/zookeeper/Manifest sys-cluster/zookeeper/zookeeper-3.3.1.ebuild
diffstat 2 files changed, 73 insertions(+), 0 deletions(-) [+]
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/sys-cluster/zookeeper/Manifest	Sun Jun 27 22:50:34 2010 +0200
@@ -0,0 +1,2 @@
+DIST zookeeper-3.3.1.tar.gz 10279804 RMD160 a911202f6271901cc6fb4b64306808f64bff6e99 SHA1 683f439c149fdeaad996eb88d84caa2f2fc756c5 SHA256 dc77ef79aea6b19d418110e9a1e916cb4c26ceb7b3acb6792af32eb2a97ea536
+EBUILD zookeeper-3.3.1.ebuild 1522 RMD160 05f6dc9a9aa92f3444bd3233061a9c22749acb79 SHA1 add0d228a8885af2aea4273314147c65ffe716da SHA256 521bd45843722d5ed0be7da8371616edc276b509ec8c5a26dc46dd640ef53033
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/sys-cluster/zookeeper/zookeeper-3.3.1.ebuild	Sun Jun 27 22:50:34 2010 +0200
@@ -0,0 +1,71 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit eutils java-utils-2
+
+MY_PN="${PN/apache-/}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="ZooKeeper is a high-performance coordination service for
+distributed applications."
+HOMEPAGE="http://hadoop.apache.org/"
+SRC_URI="mirror://apache/hadoop/${MY_PN}/${MY_P}/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="mirror binchecks"
+IUSE=""
+
+DEPEND=""
+RDEPEND=">=virtual/jre-1.6"
+
+S="${WORKDIR}/${MY_P}"
+INSTALL_DIR=/opt/"${PN}"
+DATA_DIR=/var/db/"${PN}"
+export CONFIG_PROTECT="${CONFIG_PROTECT} ${INSTALL_DIR}/conf"
+
+src_install() {
+	dodir "${DATA_DIR}"
+	sed "s:^dataDir=.*:dataDir=${DATA_DIR}:" conf/zoo_sample.cfg > conf/zoo.cfg || die "sed failed"
+
+	dodir "${INSTALL_DIR}"
+	mv "${S}"/* "${D}${INSTALL_DIR}" || die "install failed"
+
+	# env file
+	cat > 99"${PN}" <<-EOF
+		PATH=${INSTALL_DIR}/bin
+		CONFIG_PROTECT=${INSTALL_DIR}/conf
+	EOF
+	doenvd 99"${PN}" || die "doenvd failed"
+
+	cat > "${PN}" <<-EOF
+		#!/sbin/runscript
+
+		opts="start stop restart"
+
+		start() {
+			${INSTALL_DIR}/bin/zkServer.sh start > /dev/null
+				}
+
+		stop() {
+			${INSTALL_DIR}/bin/zkServer.sh stop
+				}
+
+		restart() {
+			${INSTALL_DIR}/bin/zkServer.sh restart > /dev/null
+				}
+
+		status() {
+			${INSTALL_DIR}/bin/zkServer.sh status
+				}
+	EOF
+	doinitd "${PN}" || die "doinitd failed"
+}
+
+pkg_postinst() {
+	elog "For info on configuration see http://hadoop.apache.org/${MY_PN}/docs/r${PV}"
+}