changeset 60:acd741f300f7

it's alive
author holger@hoho.dyndns.org
date Fri, 15 Aug 2008 14:45:55 +0200
parents 6a65c52cb465
children efdeddd494e9 fe9845360ff0
files net-misc/rabbitmq-server/Manifest net-misc/rabbitmq-server/rabbitmq-server-1.4.0.ebuild
diffstat 2 files changed, 18 insertions(+), 30 deletions(-) [+]
line wrap: on
line diff
--- a/net-misc/rabbitmq-server/Manifest	Fri Aug 15 14:00:48 2008 +0200
+++ b/net-misc/rabbitmq-server/Manifest	Fri Aug 15 14:45:55 2008 +0200
@@ -1,3 +1,2 @@
 DIST rabbitmq-server-generic-unix-1.4.0.tar.gz 394991 RMD160 f3ced06ec6f8ced09a9e0f5c60f0b73954ea8634 SHA1 bea27fa2255324f13e343ed82c50e69c6983628a SHA256 642ffe9cdca8ac5bd030647d24d60cca388df20f1d6a5913c3a2ae036f75018e
-EBUILD rabbitmq-server-1.4.0.ebuild 1806 RMD160 7742423a59044c88b60d6630a5801af1198c812e SHA1 1820479e2675c98fdc10041ee609bdd2222ffe59 SHA256 2c17ecb65e7535745e6e0325c7db50cf50ef8252f086fbf007325e9c0a36d054
-MISC rabbitmq-server-1.4.0.ebuild~ 1819 RMD160 ddc1e00a0a73fd14439091eb143576e02acc6749 SHA1 e2c8f77df35b260faa31d8d0f895fda45c4d41cc SHA256 d098ff3ea3fb591e1cd5cbef177ea98219c77acfe50e897b534b5a989f45d920
+EBUILD rabbitmq-server-1.4.0.ebuild 1066 RMD160 98d1bc0fa46375677176adcd9bcc58c6eb032b60 SHA1 b4f135e52539a267c105cda6199207850ce9ed7c SHA256 15693e4118e305c5e0c8437db3dd1bdd0a427fe5e917e9f3e0a18606931561e4
--- a/net-misc/rabbitmq-server/rabbitmq-server-1.4.0.ebuild	Fri Aug 15 14:00:48 2008 +0200
+++ b/net-misc/rabbitmq-server/rabbitmq-server-1.4.0.ebuild	Fri Aug 15 14:45:55 2008 +0200
@@ -12,40 +12,29 @@
 KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
 IUSE=""
  
-# HH: is RDEPEND-only sufficient for a binary package?
+# Q: is RDEPEND-only sufficient for a binary package, since we don't compile?
 DEPEND="dev-lang/erlang"
 RDEPEND="${DEPEND}"
 
-# Source directory; the dir where the sources can be found (automatically
-# unpacked) inside ${WORKDIR}.  The default value for S is ${WORKDIR}/${P}
-# If you don't need to change it, leave the S= line out of the ebuild 
-# to keep it tidy. 
+# grr: the packaged directory contains an underscore
 S="${WORKDIR}/rabbitmq_server-${PV}"
 
 src_install() {
+	# the local erlang module directory
+	local targetdir="/usr/$(get_libdir)/erlang/lib/${P}"
+
+	# scripts
+	dosbin sbin/*
+
+	# erlang module
+	dodir "${targetdir}"
+	cp -dpR ebin include src "${D}/${targetdir}"
+
+	# docs
 	dodoc INSTALL LICENSE LICENSE-MPL-RabbitMQ
 
-	# You must *personally verify* that this trick doesn't install
-	# anything outside of DESTDIR; do this by reading and
-	# understanding the install part of the Makefiles.
-	# This is the preferred way to install.
-	#emake DESTDIR="${D}" install || die "emake install failed"
-
-	# For Makefiles that don't make proper use of DESTDIR, setting
-	# prefix is often an alternative.  However if you do this, then
-	# you also need to specify mandir and infodir, since they were
-	# passed to ./configure as absolute paths (overriding the prefix
-	# setting).
-	#emake \
-	#	prefix="${D}"/usr \
-	#	mandir="${D}"/usr/share/man \
-	#	infodir="${D}"/usr/share/info \
-	#	libdir="${D}"/usr/$(get_libdir) \
-	#	install || die "emake install failed"
-	# Again, verify the Makefiles!  We don't want anything falling
-	# outside of ${D}.
-
-	# The portage shortcut to the above command is simply:
-	#
-	#einstall || die "einstall failed"
+	# TODO:
+	# config to set env vars as per INSTALL?
+	# set LOGDIR to /var/log/rabbitmq.log
+	# run as different user?
 }