changeset 221:da2e11c54daa

add an ebuild for the latest exaile version - doesn't work yet as it depends on a non-existing pygtk version. see https://bugs.launchpad.net/exaile/+bug/583101
author Dirk Olmes <dirk@xanthippe.ping.de>
date Wed, 04 Aug 2010 13:44:58 +0200
parents ea975b812fa2
children 86a0cec24d06
files media-sound/exaile/Manifest media-sound/exaile/exaile-0.3.2.0.ebuild
diffstat 2 files changed, 79 insertions(+), 0 deletions(-) [+]
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/media-sound/exaile/Manifest	Wed Aug 04 13:44:58 2010 +0200
@@ -0,0 +1,2 @@
+DIST exaile-0.3.2.0.tar.gz 2082057 RMD160 70f28f71eac10178a29bab98844a1a1e48f39006 SHA1 08015ab647f5b83997bd2f1c87c14d3d287fd3e7 SHA256 7571db88db5453d09675ed70d8bd5046825b6e7b79ea76b01707e11cd14609eb
+EBUILD exaile-0.3.2.0.ebuild 1759 RMD160 882e47129a0d5e8fe671fc0fe56174c95333b5b0 SHA1 ccc09f44d05ed78f5b454dc2f281f58bd236cabb SHA256 d0b49e48cced5d34c4f795a5455b28ce06328853b0ca2ea2271f69214d2488ac
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/media-sound/exaile/exaile-0.3.2.0.ebuild	Wed Aug 04 13:44:58 2010 +0200
@@ -0,0 +1,77 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/exaile/exaile-0.3.1.1.ebuild,v 1.1 2010/04/16 11:37:14 ssuominen Exp $
+
+EAPI=2
+
+PYTHON_DEPEND="2:2.6"
+PYTHON_USE_WITH="sqlite"
+
+inherit fdo-mime multilib python
+
+DESCRIPTION="a media player aiming to be similar to AmaroK, but for GTK+"
+HOMEPAGE="http://www.exaile.org/"
+SRC_URI="http://launchpad.net/exaile/0.3.2/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-2 GPL-3"
+SLOT="0"
+#KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+KEYWORDS=""
+IUSE="cddb libnotify nls"
+
+RDEPEND="dev-python/dbus-python
+	>=media-libs/mutagen-1.10
+	>=dev-python/pygtk-2.17
+	>=dev-python/pygobject-2.18
+	dev-python/gst-python:0.10
+	media-libs/gst-plugins-good:0.10
+	media-plugins/gst-plugins-meta:0.10
+	libnotify? ( dev-python/notify-python )
+	cddb? ( dev-python/cddb-py )"
+DEPEND="nls? ( dev-util/intltool
+	sys-devel/gettext )"
+
+# Required python 'mox' module missing wrt #315589
+RESTRICT="test"
+
+pkg_setup() {
+	python_set_active_version 2
+}
+
+src_prepare() {
+	sed -i \
+		-e "s:exec python:exec $(PYTHON):" \
+		exaile tools/generate-launcher || die
+}
+
+src_compile() {
+	if use nls; then
+		emake locale || die
+	fi
+}
+
+src_install() {
+	local _no_locale
+	use nls || _no_locale=_no_locale
+
+	emake PREFIX="/usr" LIBINSTALLDIR="/$(get_libdir)" DESTDIR="${D}" \
+		install${_no_locale} || die
+
+	dodoc README
+
+	insinto /usr/share/exaile/data
+	doins -r data/migrations || die
+}
+
+pkg_postinst() {
+	python_need_rebuild
+	python_mod_optimize /usr/$(get_libdir)/${PN}
+	fdo-mime_desktop_database_update
+	fdo-mime_mime_database_update
+}
+
+pkg_postrm() {
+	python_mod_cleanup /usr/$(get_libdir)/${PN}
+	fdo-mime_desktop_database_update
+	fdo-mime_mime_database_update
+}