changeset 508:eca2d2f85dc5

newer ebuild for bogofilter
author Dirk Olmes <dirk@xanthippe.ping.de>
date Sun, 22 Mar 2020 03:01:04 +0100
parents 43d28a985b5c
children 4c9f6797d0f4
files mail-filter/bogofilter/Manifest mail-filter/bogofilter/bogofilter-1.2.5.ebuild
diffstat 2 files changed, 131 insertions(+), 0 deletions(-) [+]
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/mail-filter/bogofilter/Manifest	Sun Mar 22 03:01:04 2020 +0100
@@ -0,0 +1,2 @@
+DIST bogofilter-1.2.5.tar.xz 801240 BLAKE2B 90fc5f0ab258ada722ca2fb79d17279b621eb089f646eade2ab41b78c44deea7f3fd8f219053e09ce5b4c64f5fc81f43a17c20b84261b22d5529c06106e80b3c SHA512 3a7280485cfe5802dd3e9721c153f88ccf28bff7a6a24590e985e860d1f1e0ddea7bde8a8e5ad1ff643e94c9fd7b26b2a5ed5a9fb991cee3fd5b0ce67ce9abfe
+EBUILD bogofilter-1.2.5.ebuild 3723 BLAKE2B ac6edfb17dc778d565140c0a972ad03ec871a76901bd4cb97204e3d7f322e00b05548f3a6866d8067de6d8c86a2abdc4d194656dfb6cfd031f962c17e76b16d8 SHA512 18c06e297d8828c32539aa7a65da54dcbf9128a57e78f21d435420e06474a47f20caf8454ac6a59084bd63565b5a034b05a8b68e8b320bcc174c1b0383c1d17e
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/mail-filter/bogofilter/bogofilter-1.2.5.ebuild	Sun Mar 22 03:01:04 2020 +0100
@@ -0,0 +1,129 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools db-use flag-o-matic toolchain-funcs
+
+DESCRIPTION="Bayesian spam filter designed with fast algorithms, and tuned for speed"
+HOMEPAGE="http://bogofilter.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ia64 ppc ppc64 ~sh ~sparc x86"
+IUSE="berkdb sqlite tokyocabinet"
+
+# pax needed for bf_tar
+DEPEND="
+	app-arch/pax
+	sci-libs/gsl:=
+	virtual/libiconv
+	berkdb?  ( >=sys-libs/db-3.2:* )
+	!berkdb? (
+		sqlite?  ( >=dev-db/sqlite-3.6.22 )
+		!sqlite? (
+			tokyocabinet? ( dev-db/tokyocabinet )
+			!tokyocabinet? ( >=sys-libs/db-3.2:* )
+		)
+	)
+"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+	has_version mail-filter/bogofilter || return 0
+	if  (   use berkdb && ! has_version 'mail-filter/bogofilter[berkdb]' ) || \
+		( ! use berkdb &&   has_version 'mail-filter/bogofilter[berkdb]' ) || \
+		(   use sqlite && ! has_version 'mail-filter/bogofilter[sqlite]' ) || \
+		( ! use sqlite &&   has_version 'mail-filter/bogofilter[sqlite]' ) || \
+		( has_version '>=mail-filter/bogofilter-1.2.1-r1' && \
+			(   use tokyocabinet && ! has_version 'mail-filter/bogofilter[tokyocabinet]' ) || \
+			( ! use tokyocabinet &&   has_version 'mail-filter/bogofilter[tokyocabinet]' )
+		) ; then
+		ewarn
+		ewarn "If you want to switch the database backend, you must dump the wordlist"
+		ewarn "with the current version (old use flags) and load it with the new version!"
+		ewarn
+	fi
+}
+
+src_prepare() {
+	default
+
+	# bug 445918
+	sed -i -e 's/ -ggdb//' configure.ac || die
+
+	# bug 421747
+	chmod +x src/tests/t.{ctype,leakfind,lexer.qpcr,lexer.eoh,message_id,queue_id}
+
+	# bug 654990
+	sed -i -e 's/t.bulkmode//' \
+		-e 's/t.dump.load//' \
+		-e 's/t.nonascii.replace//' \
+		src/tests/Makefile.am || die
+
+	eautoreconf
+}
+
+src_configure() {
+	local myconf="" berkdb=true
+	myconf="--without-included-gsl"
+
+	# determine backend: berkdb *is* default
+	if use berkdb && use sqlite ; then
+		elog "Both useflags berkdb and sqlite are in USE:"
+		elog "Using berkdb as database backend."
+	elif use berkdb && use tokyocabinet ; then
+		elog "Both useflags berkdb and tokyocabinet are in USE:"
+		elog "Using berkdb as database backend."
+	elif use sqlite && use tokyocabinet ; then
+		elog "Both useflags sqlite and tokyocabinet are in USE:"
+		elog "Using sqlite as database backend."
+		myconf="${myconf} --with-database=sqlite"
+		berkdb=false
+	elif use sqlite ; then
+		myconf="${myconf} --with-database=sqlite"
+		berkdb=false
+	elif use tokyocabinet ; then
+		myconf="${myconf} --with-database=tokyocabinet"
+		berkdb=false
+	elif ! use berkdb ; then
+		elog "Neither berkdb nor sqlite nor tokyocabinet are in USE:"
+		elog "Using berkdb as database backend."
+	fi
+
+	# Include the right berkdb headers for FreeBSD
+	if ${berkdb} ; then
+		append-cppflags "-I$(db_includedir)"
+	fi
+
+	econf ${myconf}
+}
+
+src_test() {
+	emake -C src/ check
+}
+
+src_install() {
+	emake DESTDIR="${D}" install
+
+	exeinto /usr/share/${PN}/contrib
+	doexe contrib/{bogofilter-qfe,parmtest,randomtrain}.sh \
+		contrib/{bfproxy,bogominitrain,mime.get.rfc822,printmaildir}.pl \
+		contrib/{spamitarium,stripsearch}.pl
+
+	insinto /usr/share/${PN}/contrib
+	doins contrib/{README.*,dot-qmail-bogofilter-default} \
+		contrib/{bogogrep.c,bogo.R,bogofilter-milter.pl,*.example} \
+		contrib/vm-bogofilter.el \
+		contrib/{trainbogo,scramble}.sh
+
+	dodoc AUTHORS NEWS README RELEASE.NOTES* TODO GETTING.STARTED \
+		doc/integrating-with-* doc/README.{db,sqlite}
+
+	dodoc -r doc/*.html
+
+	dodir /usr/share/doc/${PF}/samples
+	mv "${D}"/etc/bogofilter.cf.example "${D}"/usr/share/doc/${PF}/samples/ || die
+	rmdir "${D}"/etc || die
+}