comparison dev-python/potr/potr-1.2.0.ebuild @ 428:1901aeaa2706

add an ebuild for the latest python-otr version
author Dirk Olmes <dirk@xanthippe.ping.de>
date Sat, 03 Dec 2016 05:24:24 +0100
parents
children 4b67abbaacee
comparison
equal deleted inserted replaced
427:18fecfcfbe40 428:1901aeaa2706
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 MY_P="python-otr-release-${PV}"
8
9 #PYTHON_COMPAT=( python{2_7,3_4} )
10 PYTHON_COMPAT=( python2_7 )
11
12 inherit distutils-r1
13
14 DESCRIPTION="Pure Python OTR implementation"
15 HOMEPAGE="https://github.com/AGProjects/python-otr/"
16 SRC_URI="https://github.com/AGProjects/python-otr/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
17
18 LICENSE="LGPL-3+"
19 SLOT="0"
20 KEYWORDS="~amd64"
21 IUSE=""
22
23 CDEPEND=">=dev-python/pycrypto-2.1[${PYTHON_USEDEP}]"
24 DEPEND="${CDEPEND}
25 dev-python/setuptools[${PYTHON_USEDEP}]
26 "
27 RDEPEND="${CDEPEND}"
28
29 S="${WORKDIR}/${MY_P}"