diff dev-python/potr/potr-1.2.0.ebuild @ 428:1901aeaa2706

add an ebuild for the latest python-otr version
author Dirk Olmes <dirk@xanthippe.ping.de>
date Sat, 03 Dec 2016 05:24:24 +0100
parents
children 4b67abbaacee
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/dev-python/potr/potr-1.2.0.ebuild	Sat Dec 03 05:24:24 2016 +0100
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MY_P="python-otr-release-${PV}"
+
+#PYTHON_COMPAT=( python{2_7,3_4} )
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure Python OTR implementation"
+HOMEPAGE="https://github.com/AGProjects/python-otr/"
+SRC_URI="https://github.com/AGProjects/python-otr/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+CDEPEND=">=dev-python/pycrypto-2.1[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}
+	dev-python/setuptools[${PYTHON_USEDEP}]
+	"
+RDEPEND="${CDEPEND}"
+
+S="${WORKDIR}/${MY_P}"