changeset 439:8bf346bb0f28

remove the outdated eric ebuild
author Dirk Olmes <dirk@xanthippe.ping.de>
date Thu, 23 Mar 2017 11:10:29 +0100
parents c999bcda270f
children d27b7787b1f8
files dev-util/eric/Manifest dev-util/eric/eric-5.4.3.ebuild
diffstat 2 files changed, 0 insertions(+), 110 deletions(-) [+]
line wrap: on
line diff
--- a/dev-util/eric/Manifest	Mon Mar 20 07:21:46 2017 +0100
+++ /dev/null	Thu Jan 01 00:00:00 1970 +0000
@@ -1,3 +0,0 @@
-DIST eric5-5.4.3.tar.gz 10477290 SHA256 3ee42ba781f9575720f9bd956a743e0db4e09bc0d3d29e4eea13f066027dd30c SHA512 c26d05f9a85e185af940d5b198ef3c0a734eba94c0e07ee5658930da39718480d69b8364e6837616de7851d0e25110bd2c6a235f3f62e01a1c83224e545e8917 WHIRLPOOL 856c023096998c06322a84910a10309cb3f80f712c165e56923ee3d2c8ead8ef2e1c8c386f86e9bd47b64b8749f5f7a265f2ef70166310110f5af2c8da260f26
-DIST eric5-i18n-de-5.4.3.tar.gz 738031 SHA256 7dae06b3f4dad7970337b8a0f5a6f8704f986ac64d897570690f6098b06628c2 SHA512 e9d370d091de76a5efc3702ad02471cbf375caf3c6834059e661a4a10b3f543f13ea8262b1ec75fc217aa589cc0e7f2fc00605794cf888ff0d722101782a084a WHIRLPOOL b238e8cca9a5b12c88fd1aa4227f72340867db3d95243d949b2cc69a7bf70177b435633b7d2c8e2427326dc5745dd21d913b857067ccfe0145f6791f68a248d3
-EBUILD eric-5.4.3.ebuild 3007 SHA256 918c48152d303c6ec2677587a803d9ed14243d9f3c6f830f3c2640e47178606b SHA512 3e29c263f37c3af443c02db1d4f953fd3cfba931d45aca9268045e362ff7ac0b1ba144a11a86bbeab3ce86c23ef0e0cf79098f17715fd4a5279de8de0ae69838 WHIRLPOOL 07042b4e470a5f7ddee65f4dec740178529d9308367582bde2d1464c5f91d19e233b911bd63148f1e1eae8170c12c9fdafd884f2a39c4d5c06e58312942d679a
--- a/dev-util/eric/eric-5.4.3.ebuild	Mon Mar 20 07:21:46 2017 +0100
+++ /dev/null	Thu Jan 01 00:00:00 1970 +0000
@@ -1,107 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/eric/eric-5.3.8.ebuild,v 1.1 2013/11/24 22:54:02 pesa Exp $
-
-EAPI=4
-
-PYTHON_DEPEND="3:3.3"
-PYTHON_USE_WITH="sqlite"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.* *-jython 2.7-pypy-*"
-
-#PLOCALES="cs de en es fr it ru tr zh_CN"
-PLOCALES="de"
-
-inherit eutils l10n python
-
-DESCRIPTION="A full featured Python IDE using PyQt4 and QScintilla"
-HOMEPAGE="http://eric-ide.python-projects.org/"
-
-SLOT="5"
-MY_PV=${PV/_pre/-snapshot-}
-MY_P=${PN}${SLOT}-${MY_PV}
-
-BASE_URI="mirror://sourceforge/eric-ide/${PN}${SLOT}/stable/${PV}"
-SRC_URI="${BASE_URI}/${MY_P}.tar.gz"
-for L in ${PLOCALES}; do
-	SRC_URI+=" linguas_${L}? ( ${BASE_URI}/${PN}${SLOT}-i18n-${L/zh_CN/zh_CN.GB2312}-${MY_PV}.tar.gz )"
-done
-unset L
-
-LICENSE="GPL-3"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE="spell"
-
-DEPEND="
-	>=dev-python/sip-4.14.3
-	>=dev-python/PyQt4-4.10[X,help,sql,svg,webkit]
-	>=dev-python/qscintilla-python-2.7.1
-"
-RDEPEND="${DEPEND}
-	>=dev-python/chardet-2.0.1
-	>=dev-python/coverage-3.2
-	>=dev-python/pygments-1.6
-"
-PDEPEND="
-	spell? ( dev-python/pyenchant )
-"
-
-S=${WORKDIR}/${MY_P}
-
-PYTHON_VERSIONED_EXECUTABLES=("/usr/bin/.*")
-
-src_prepare() {
-	# Avoid file collisions between different slots of Eric.
-	sed -i -e 's/^Icon=eric$/&5/' eric/eric5.desktop || die
-	sed -i -e 's/\([^[:alnum:]]\)eric\.png\([^[:alnum:]]\)/\1eric5.png\2/' \
-		$(grep -lr 'eric\.png' .) || die
-	mv eric/icons/default/eric{,5}.png || die
-	mv eric/pixmaps/eric{,5}.png || die
-	rm -f eric/APIs/Python/zope-*.api
-	rm -f eric/APIs/Ruby/Ruby-*.api
-
-	# Delete internal copies of dev-python/chardet,
-	# dev-python/coverage and dev-python/pygments.
-	rm -fr eric/ThirdParty
-	rm -fr eric/DebugClients/Python{,3}/coverage
-	sed -i -e 's/from DebugClients\.Python3\?\.coverage/from coverage/' \
-		$(grep -lr 'from DebugClients\.Python3\?\.coverage' .) || die
-
-	# Fix desktop files (bug 458092).
-	sed -i -e '/^Categories=/s:Python:X-&:' eric/eric5{,_webbrowser}.desktop || die
-}
-
-src_install() {
-	installation() {
-		"$(PYTHON)" install.py \
-			-z \
-			-b "${EPREFIX}/usr/bin" \
-			-i "${T}/images/${PYTHON_ABI}" \
-			-d "${EPREFIX}$(python_get_sitedir)" \
-			-c
-	}
-	python_execute_function installation
-	python_merge_intermediate_installation_images "${T}/images"
-
-	doicon eric/icons/default/eric5.png || die
-}
-
-pkg_postinst() {
-	python_mod_optimize -x "/eric5/(DebugClients/Python|UtilitiesPython2)/" eric5{,config.py,plugins}
-
-	elog
-	elog "If you want to use Eric with mod_python, have a look at"
-	elog "\"${EROOT}$(python_get_sitedir -b -f)/eric5/patch_modpython.py\"."
-	elog
-	elog "The following packages will give Eric extended functionality:"
-	elog "  dev-python/pylint"
-	elog "  dev-python/pysvn"
-	elog
-	elog "This version has a plugin interface with plugin-autofetch from"
-	elog "the application itself. You may want to check those as well."
-	elog
-}
-
-pkg_postrm() {
-	python_mod_cleanup eric5{,config.py,plugins}
-}